Service Disruption to Mastercard and Maestro Transaction Processing
Incident Report for Gravity Payments
Resolved
As of 4:30 am on June 22, this incident has been resolved. The incident has been fully resolved and client impact has ceased. The incident was caused by an internal problem at a MasterCard and Maestro.
Posted Jun 22, 2023 - 09:10 PDT
Monitoring
We have observed some improvement; however, the work to fully resolve the disruption in service to Mastercard and Maestro transaction processing continues. The next update will be provided on the morning of 06/22/2023 or once the incident is fully resolved.
Posted Jun 21, 2023 - 20:22 PDT
Identified
We have been made aware of a potential service disruption which is impacting Mastercard and Maestro transaction processing on multiple platforms. We advise that you use a different payment method at this time. Progress is being made to resolve the issue. Updates will continue to be provided as soon as possible.
Posted Jun 21, 2023 - 13:47 PDT