Unable to process with American Express
Incident Report for Gravity Payments
Resolved
This incident has been resolved.
Posted Nov 19, 2022 - 17:35 PST
Update
Fiserv has acknowledged that this is an American Express network outage. For the time being, please utilize another card service while this issue persists.
Posted Nov 18, 2022 - 17:42 PST
Investigating
You may experience issues processing with American Express cards. This appears to be a widespread issue with Amex and not localized to Gravity Payments. There is no official confirmation from Fiserv or Amex regarding the outage. For the time being, please utilize another card service and we will keep you posted.
Posted Nov 18, 2022 - 17:28 PST