We have monitored this issue for 24 hours and confirmed it has been resolved.
If you are having any difficulties, please contact our support team at support@gravitypayments.com or call tel:8667014700.
Posted Jun 13, 2025 - 12:14 PDT
Update
Due to this issue, we are experiencing high call volume. If you are unable to run transactions and need assistance, we can resolve this issue for you remotely.
Please submit a ticket via the form on our website at gravitypayments.com/support and include the subject line “Service disruption 6-12-25”.
Posted Jun 12, 2025 - 03:15 PDT
Identified
Some merchants are currently experiencing intermittent “Transarmor failed” errors on some terminals. As a result, these merchants may have issues processing payments.
We have identified the cause of this issue. If you are seeing this error, please contact our support team at support@gravitypayments.com or call tel:8667014700.
Posted Jun 11, 2025 - 16:46 PDT
Investigating
We are currently investigating the issue and will update this page with more information soon.
If you are having any difficulties, please contact our support team at support@gravitypayments.com or call tel:8667014700.