Clover Ecomm - Degraded Performance

Incident Report for Gravity Payments

Resolved

This incident is now resolved.

If you are still having problems with online transactions, please contact our support team at support@gravitypayments.com or call tel:8667014700.
Posted Aug 15, 2025 - 16:00 PDT

Investigating

We've been made aware of an issue with the Clover Online Ordering, Clover Virtual Terminal, and API calls to Clover Gateway impacting some Clover merchants.

If you are having problems with online transactions, please contact our support team at support@gravitypayments.com or call tel:8667014700.
Posted Aug 15, 2025 - 11:00 PDT