Support Phone Line Service Disruption
Incident Report for Gravity Payments
Resolved
This incident has been resolved.
Posted May 20, 2024 - 14:46 PDT
Investigating
We are currently experiencing intermittent issues with our phone lines disconnecting when you try to dial in. Please retry our number or you can email our support team at support@gravitypayments.com. Thank you for your patience.
Posted May 20, 2024 - 13:19 PDT