Support Phone Line Service Disruption
Incident Report for Gravity Payments
Resolved
This incident is now resolved.

If you are having difficulties reaching our support team over the phone, please email us at support@gravitypayments.com.

Thank you for your patience during this incident!
Posted Jan 23, 2025 - 11:08 PST
Monitoring
A fix has been implemented, and our teams are observing service restoration. You can now contact our support team at (866) 701-4700.

If you are having difficulties reaching our support team over the phone, please email us at support@gravitypayments.com.

Thank you for your patience as this issue gets fully resolved.
Posted Jan 23, 2025 - 07:35 PST
Investigating
We are experiencing intermittent disruptions with our phone service which may affect your ability to reach us. For support, please email us at support@gravitypayments.com.

Thank you for your patience as this issue gets resolved.
Posted Jan 22, 2025 - 10:58 PST