Possible "Invalid Batch" error

Incident Report for Gravity Payments

Resolved

This incident has been resolved.
Posted Jun 06, 2025 - 07:40 PDT

Monitoring

Merchants utilizing older software versions of PAX S300 and Verifone VX 520 terminals could receive an invalid batch error if they have a refund within their batch.

Merchants should run refunds through a virtual terminal gateway via dashboard in order to prevent this error.

If you do receive this error, please contact our support team by calling tel:8667014700 or emailing support@gravitypayments.com to resolve the issue.
Posted Jun 05, 2025 - 05:45 PDT