Clover - Service Disruption

Incident Report for Gravity Payments

Resolved

This incidnet is now resolved.

If you are still having issues with the service, please email our support team at Techsupport@gravitypayments.com or call us at 866-701-4700.
Posted Apr 01, 2025 - 08:15 PDT

Investigating

We are currently experiencing service interruptions with Clover devices that impact transaction processing. We are working with Clover to identify the cause of the issue and work toward resolution.

If your device is prompting you for a passcode and you are unable to or you get an error when you attempt to enter it, please restart the device and then enter the passcode.

After the restart, if you are still having issues with the service, please contact our support team at Techsupport@gravitypayments.com or by calling us at 866-701-4700.
Posted Mar 31, 2025 - 06:49 PDT
This incident affected: emergepay and Processing Services.