Issues processing payments on Clover devices have been resolved.
If you experience issues processing payments on your Clover device or need assistance reconciling your transactions, please reach out to our team at support@gravitypayments.com or call tel :8667014700.
Posted Nov 21, 2025 - 19:19 PST
Update
Clover has communicated that they have identified the issue and are working to fully restore services to Clover devices. We are continuing to observe higher transaction success rates. We will continue to monitor until services are restored.
Posted Nov 21, 2025 - 18:53 PST
Update
We are still monitoring a decrease in error rates for transactions on Clover devices. Clover has not identified a fix for the issue yet. We are continuing to monitor.
If you are experiencing issues processing, and have access to Gravity Dashboard Virtual Terminal, please try processing directly through Virtual Terminal. Login to Gravity Dashboard, navigate to Virtual Terminal in the left-hand navigation. Next, select Sale and manually enter the amount and the customer’s card information. Click ‘Process’.
Thank you for your patience while this issue is being resolved.
Posted Nov 21, 2025 - 18:08 PST
Update
We are monitoring a decrease in transaction failures on Clover devices. We are continuing to monitor Clover.
Posted Nov 21, 2025 - 17:05 PST
Update
Clover is continuing to experience device issues. Clover has not identified a fix for the issue yet. We are monitoring Clover closely for resolution and we will continue to post updates as we have them .
Posted Nov 21, 2025 - 16:20 PST
Update
Clover is continuing to experience device issues. Clover has not identified a fix for the issue yet. We will continue to post updates as they are available.
Posted Nov 21, 2025 - 15:03 PST
Update
Clover is continuing to experience device issues. Gravity Payments is communicating closely with Clover on this issue. We will continue to post updates as they are available.
Posted Nov 21, 2025 - 14:05 PST
Investigating
Clover is currently experiencing device issues. As a result, you may receive an error message, such as a connection timeout or a syncing issue.
If you continue to experience issues processing, and have access to Gravity Dashboard Virtual Terminal, please try processing directly through Virtual Terminal. Login to Gravity Dashboard, navigate to Virtual Terminal in the left-hand navigation. Next, select Sale and manually enter the amount and the customer’s card information. Click ‘Process’.