Widespread Crowdstrike/Microsoft outage
Incident Report for Gravity Payments
Resolved
At this time, Gravity Payment's customer-facing systems are all working as expected and providing service to our customers. If you are having difficulties processing transactions please contact our support team at support@gravitypayments.com or call at (866) 701-4700.
Posted Jul 19, 2024 - 14:10 PDT
Monitoring
Call volume may be higher than expected right now as we help customers impacted by a widespread Crowdstrike/Microsoft outage.

At this time, Gravity Payment's customer-facing systems are all working as expected and providing service to our customers. If you are having difficulties processing transactions please contact our support team at support@gravitypayments.com or call at (866) 701-4700.
Posted Jul 19, 2024 - 10:24 PDT
Investigating
Call volume may be higher than expected right now as we help customers impacted by a widespread Crowdstrike/Microsoft outage.

At this time, Gravity Payment's customer-facing systems are all working as expected and providing service to our customers. If you are having difficulties processing transactions please contact our support team at support@gravitypayments.com or call at (866) 701-4700.
Posted Jul 19, 2024 - 06:51 PDT