We have pushed fixes to all affected customers. If you have any questions or further issues, please contact our support team at support@gravitypayments.com or call tel: 8667014700.
Posted Jun 02, 2025 - 11:05 PDT
Monitoring
All merchants unable to run transactions have had fix pushed to them. If you are having any issues running transactions or have questions about surcharging today, please contact us at tel:8667014700 or support@gravitypayments.com
Posted Jun 02, 2025 - 09:31 PDT
Update
We are continuing to push a fix through for the merchants affected.
Posted Jun 02, 2025 - 08:52 PDT
Update
We are continuing to push a fix through for the merchants affected.
Posted Jun 02, 2025 - 08:40 PDT
Identified
Clover devices will process transactions, but without surcharges. PAX devices will not be able to process transactions.
We have identified the issue and are pushing a fix over the course of the next 15-30 minutes.