Clover Degraded Service
Incident Report for Gravity Payments
Resolved
Clover has reported that they are no longer experiencing degraded performance, all services are back up.

For more information regarding this outage, please visit Clovers status page here: https://status.clover.com/incidents/x9lff83f4wqx
Posted Feb 04, 2024 - 14:12 PST
Identified
We are currently experiencing service disruptions with Clover card terminals. As a result, you may have issues processing transactions at this time.

If you are having difficulties processing transactions please contact our support team at support@gravitypayments.com or call at (866) 701-4700.

Thank you for your patience while this issue is being resolved.
Posted Feb 03, 2024 - 11:39 PST
This incident affected: emergepay and Processing Services.