Clover - Service Disruption

Incident Report for Gravity Payments

Resolved

This issue has been resolved.

Should you encounter any problems with our service, please contact our support team at support@gravitypayments.com or by calling us at 866-701-4700.
Posted Mar 28, 2025 - 12:50 PDT

Investigating

We are currently experiencing service interruptions with Clover devices that impact transaction processing. We are working with Clover to identify the cause of the issue and work toward resolution.

Should you encounter any problems with our service, please contact our support team at support@gravitypayments.com or by calling us at 866-701-4700.
Posted Mar 28, 2025 - 12:11 PDT