Investigating an issue with some payment web forms

Incident Report for Gravity Payments

Resolved

Issue affecting some merchants ability to process payments through web forms that were missing some assets has been resolved as of approximately 8:00AM PT. If you are having any issues, please reach out to support@gravitypayments.com or call 866-701-4700.
Posted Jun 03, 2025 - 08:26 PDT

Investigating

We are investigating this issue and will provide more information soon.
Posted Jun 03, 2025 - 07:41 PDT