EIServer merchants may be unable to run transactions

Incident Report for Gravity Payments

Resolved

This issue has been resolved.

If you are having any difficulties, please contact our support team at support@gravitypayments.com or call tel:8667014700.
Posted Apr 14, 2026 - 15:29 PDT

Monitoring

We expect the issue to be resolved for most merchants and are continuing to monitor.

If you are having any difficulties, please contact our support team at support@gravitypayments.com or call tel:8667014700.
Posted Apr 14, 2026 - 15:16 PDT

Identified

We have identified the issue and are working to resolve.

If you are having any difficulties, please contact our support team at support@gravitypayments.com or call tel:8667014700.
Posted Apr 14, 2026 - 13:17 PDT