Intermittent issues with our phone system
Incident Report for Gravity Payments
Resolved
Our phone system is currently operating as expected.
Posted Jul 03, 2023 - 20:16 PDT
Identified
The issue has been identified and workarounds are being explored. If you are unable to contact us through a phone call, please email us at support@gravitypayments.com
Posted Jul 03, 2023 - 19:27 PDT
Investigating
Please be advised we are experiencing intermittent issues with our support phone system. For assistance please email us at support@gravitypayments.com
Posted Jul 03, 2023 - 19:06 PDT