We are continuing to work on a fix for this issue.
Posted Aug 25, 2026 - 06:06 PDT
Update
Clover is experiencing issues with processing. As a result, you will experience issues with transaction processing.
Please try processing outside of your software integration directly through the Gravity Dashboard Virtual Terminal.
Process through the Gravity Dashboard’s virtual terminal. 1. Login to Gravity Dashboard, navigate to Virtual Terminal in the left hand navigation 2. Next select Sale and manually enter the amount and customer’s card information. 3. Click ‘Process’
Additionally you can process through your Clover as a standalone device:
Process through the Clover Device as standalone. 1. Tap 4 corners of the screen and input passcode 2. Select the “Sale” app 3. Input amount and then process payment
Posted Aug 25, 2026 - 05:59 PDT
Identified
Our partner Clover is experiencing a service disruption that is causing intermittent impact on our service. As a result, you may have issues processing transactions at this time. Cloverteams are working on resolution.