Clover - Service Disruption
Incident Report for Gravity Payments
Resolved
This incident has been resolved by Clover.
Posted Jun 04, 2024 - 14:01 PDT
Investigating
We are currently experiencing intermittent service disruptions with Clover. As a result, you may have issues processing transactions at this time. Clover is aware and working on a resolution.

If you are having difficulties processing transactions please contact our support team at support@gravitypayments.com or call at (866) 701-4700.
Posted Jun 04, 2024 - 11:26 PDT