Clover - Service Disruption

Incident Report for Gravity Payments

Resolved

Clover has confirmed their issue is resolved. All Clover systems should be working as expected and back online.

Please note that if you accept tips, and you were previously unable to make tip adjustments on your device, please ensure you do so before end-of-day to ensure they are captured.

If you are still experiencing any issues please contact our support team at support@gravitypayments.com or by calling us at 866-701-4700.
Posted Mar 14, 2025 - 13:19 PDT

Update

We are continuing to investigate this issue.
Posted Mar 14, 2025 - 13:18 PDT

Investigating

We are currently experiencing service interruptions with Clover devices that impact transaction processing. We are working with Clover to identify the cause of the issue and work toward resolution.

If you are completely down please contact support at 866-701-4700 for workaround assistance.
Posted Mar 14, 2025 - 12:07 PDT
This incident affected: emergepay and Processing Services.