Clover - Service Disruption

Incident Report for Gravity Payments

Resolved

This incident has been resolved by the Clover team.

If you still need support, please reach out to our team at support@gravitypayments.com or call tel :8667014700.
Posted Aug 14, 2025 - 13:38 PDT

Monitoring

We are currently monitoring intermittent connection disruptions with Clover devices. As a result, you may have issues processing transactions.

If you need support, please reach out to our team at support@gravitypayments.com or call tel :8667014700.
Posted Aug 14, 2025 - 12:14 PDT

Investigating

We are currently monitoring intermittent connection disruptions with Clover devices. As a result, you may have issues processing transactions.

If you need support, please reach out to our team at support@gravitypayments.com or call tel :8667014700.
Posted Aug 14, 2025 - 12:07 PDT
This incident affected: emergepay.