The earlier internet-related service disruption has been fully resolved. Our website and all Gravity Payments services- including transaction processing, dashboards, and APIs - are operating normally.
Systems affected through upstream providers have stabilized, and partners who experienced intermittent issues are reporting normal behavior again. No further impact is expected at this time.
If you continue to experience any processing issues, please contact our support team at support@gravitypayments.com or 866-701-4700.
Posted Nov 18, 2025 - 10:41 PST
Update
Earlier internet service disruptions affecting our website and some integrated partners are now largely resolved. Most connected services are recovering, and partners who previously reported transaction failures are now trending back to normal.
Our website (gravitypayments.com) and all core Gravity Payments services (processing, dashboard, APIs) remain operational.
Some partners may still experience brief or intermittent issues as upstream systems continue to stabilize.
If you are still experiencing difficulties processing transactions, please contact our support team at support@gravitypayments.com or call 866-701-4700.
Posted Nov 18, 2025 - 07:23 PST
Monitoring
The Gravity Payments website (gravitypayments.com) is now available.
All core Gravity Payments services (processing, dashboard, APIs) remain operational.
Lingering minor issues may cause transaction processing failures for merchants whose integrated partners utilize Cloudflare services.
If you are having any difficulties processing transactions, please contact our support team at support@gravitypayments.com or call tel:8667014700.
Posted Nov 18, 2025 - 06:59 PST
Identified
The Gravity Payments website (gravitypayments.com) is currently unavailable due to an outage with Cloudflare, a major provider of internet services.
All core Gravity Payments services (processing, dashboard, APIs) are operational.
A small number of merchants may experience transaction processing issues if using integrated partners utilizing Cloudflare services.
We are monitoring the situation and will update here as soon as possible. If you are having any difficulties processing transactions, please contact our support team at support@gravitypayments.com or call tel:8667014700.