Dispute Manager - Service Disruption

Incident Report for Gravity Payments

Resolved

This incident has been resolved.

If you need assistance retrieving information on a chargeback or posting a response, please contact our support team at support@gravitypayments.com or call tel :8667014700
Posted Jul 29, 2025 - 14:41 PDT

Investigating

We are aware of a third-party outage impacting the Dispute Manager tool, used for managing your chargebacks online.

If you need assistance retrieving information on a chargeback or posting a response, please contact our support team at support@gravitypayments.com or call tel :8667014700
Posted Jul 28, 2025 - 14:32 PDT