USAePay - issues with processing through Castle Vega devices
Incident Report for Gravity Payments
Resolved
This incident has been resolved.

If you are having difficulties processing transactions, please contact our support team at support@gravitypayments.com or call at (866) 701-4700.
Posted Jul 23, 2024 - 10:14 PDT
Investigating
We are currently experiencing service disruptions with Castle Vegas card terminals. As a result, you may have issues processing transactions at this time.

If you are having difficulties processing transactions, please contact our support team at support@gravitypayments.com or call at (866) 701-4700.
Posted Jul 23, 2024 - 07:20 PDT