USAePay - Service Disruption

Incident Report for Gravity Payments

Resolved

The incident is now resolved.

If you are still having difficulties processing transactions, please contact our support team at support@gravitypayments.com or call tel: 8667014700.
Posted May 28, 2025 - 12:30 PDT

Monitoring

A fix has been implemented, and we are seeing improvement. We continue to monitor.

If you are having difficulties processing transactions, please contact our support team at support@gravitypayments.com or call tel: 8667014700.
Posted May 28, 2025 - 12:20 PDT

Identified

The issue has been identified and a fix has been implemented.

If you are having difficulties processing transactions, please contact our support team at support@gravitypayments.com or call tel: 8667014700.
Posted May 28, 2025 - 12:14 PDT

Investigating

We are currently experiencing intermittent service disruptions with USAePay. As a result, you may have issues processing transactions at this time.

If you are having difficulties processing transactions, please contact our support team at support@gravitypayments.com or call tel: 8667014700.
Posted May 28, 2025 - 10:26 PDT
This incident affected: emergepay.