Clover Outage

Incident Report for Gravity Payments

Resolved

Clover is recovered at this point and we will continue to monitor.
Posted Aug 24, 2026 - 11:05 PDT

Identified

Clover is currently experiencing a service outage that may affect some of your services or devices.

If you are unable to process transactions, please contact our support team at (866) 701-4700 or email us at support@gravitypayments.com.
Posted Aug 24, 2026 - 10:56 PDT
This incident affected: emergepay.