Gravity Payments Website - Performance Degradation

Incident Report for Gravity Payments

Resolved

This incident has been resolved. The Gravity Payments website is up and running as expected.
Posted Apr 07, 2025 - 17:53 PDT

Identified

We are currently experiencing intermittent issues with our website that may impact accessibility for some users. Our team is actively working to resolve the issue as quickly as possible.

We apologize for any inconvenience and appreciate your patience. Direct access to dashboard services via dashboard.gravitypayments.com remains available.
Posted Apr 07, 2025 - 17:17 PDT