USAePay - Service Disruption

Incident Report for Gravity Payments

Resolved

This incident has been resolved.

If you are still having difficulties processing transactions, please contact our support team at support@gravitypayments.com or call at tel: 8667014700.
Posted May 07, 2025 - 07:02 PDT

Monitoring

The service has returned to normal, and we are monitoring for any further issues.

If you are still having difficulties processing transactions, please contact our support team at support@gravitypayments.com or call at tel: 8667014700.
Posted May 07, 2025 - 06:45 PDT

Identified

We are currently experiencing intermittent service disruptions with USAePay. As a result, you may have issues processing card-not-present transactions at this time.

If you are having difficulties processing transactions, please contact our support team at support@gravitypayments.com or call tel: 8667014700.
Posted May 07, 2025 - 06:27 PDT
This incident affected: emergepay.