DIS - Service Disruption

Incident Report for Gravity Payments

Resolved

Our partner DIS has resolved the issue on their side. All services should be running as expected.

If you need support, please contact our support team at support@gravitypayments.com or call tel :8667014700.
Posted Aug 04, 2025 - 10:13 PDT

Update

Our Partner DIS continues to work on a resolution, and we remain in communication with them. As a workaround, you can use Dashboard Virtual Terminal at dashboard.gravitypayments.com.

If you need support, please contact our support team at support@gravitypayments.com or call tel :8667014700.

Thank you for your patience while this issue is being resolved.
Posted Aug 04, 2025 - 09:09 PDT

Identified

Our partner DIS is experiencing a service disruption that is causing intermittent impact on our service. As a result, you may have issues processing transactions at this time. DIS teams are working on resolving the issue.

If you need support, please contact our support team at support@gravitypayments.com or call tel :8667014700.

Thank you for your patience while this issue is being resolved.
Posted Aug 04, 2025 - 08:45 PDT
This incident affected: Processing Services.